Author Topic: *Prob w/ SLOW Speed/Need Settings Update*  (Read 840 times)

Offline left4dead

  • A New Nut
  • *
  • Posts: 41
  • I'm a llama!
*Prob w/ SLOW Speed/Need Settings Update*
« on: August 06, 2004, 01:11:18 am »
Hi,

My speed has dropped by almost 50% within the past week (from 2400+ kbps down to 1100+ kbps) and I don't understand WHY. My system is virus and spyware free (ran Spybot, Ad-Aware, Spy Sweeper and Norton AV). Can someone please recommend something to resolve this problem. Thanks in advance!  :)

OS: Windows XP
ISP: Adelphia Cable (3000/256)
Current CN Settings:

DefaultReceiveWindow = 384000
DefaultSendWindow = 32768
DisableAddressSharing = 1
InitialLargeBufferCount = 200
InitialMediumBufferCount = 480
InitialSmallBufferCount = 640
LargeBufferSize = 81920
MaxFastTransmit = 64000
MediumBufferSize = 150400
PriorityBoost = 0
SmallBufferSize = 12800
TransmitWorker = 32
FastSendDatagramThreshold = 1024
EnableFastRouteLookup = 1
EnablePMTUDiscovery = 1
IgnorePushBitsOnReceive = 0
GlobalMaxTcpWindowSize = blank
MaxFreeTcbs = 8000
MaxHashTableSize = 16384
MaxNormLookupMemory = 5000000
SackOpts = 1
SynAttackProtect = 1
Tcp1323Opts = 1
TcpLogLevel = 1
TcpMaxDupAcks = 2
TcpMaxHalfOpen = 100
TcpMaxHalfRetried = 80
TcpRecvSegmentSize = 1460
TcpSendSegmentSize = 1460
TcpTimedWaitDelay = 30
TcpUseRFC1122UrgentPointer = 0
TcpWindowSize = blank
MaxConnectionsPer1_0Server = 10
MaxConnectionsPerServer = 10
DefaultTTL = 64
DisableUserTOSSetting = 0
TcpMaxDataRetransmissions = 6
DefaultTOSValue = 240

TC/IP Analyzer:

TCP properties for IP = XXXXXXXXXX ()
Browser/OS = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; MSN 9.0;MSN 9.1; MSNbMSNI; MSNmen-us; MSNcOTH)
Notes: Read the Analyzer FAQ if the above is not your IP address.

TCP options string = 020405b40103030001010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which equals MSS.
 
Default Receive Window (RWIN) = 64240
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 64240

RWIN is a multiple of MSS
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)  
bandwidth * delay product (Note this is not a speed test):

Your RcvWindow limits you to: 2569.6 kbps (321.2 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1027.84 kbps (128.48 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 54 hops

TTL value is ok.
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349) = 11110000

Precedence (priority) = 000 (routine)
Delay = 0 (normal delay)
Throughput = 1 (high throughput)
Reliability = 1 (high reliability)
Cost = 1 (low cost)



Offline dannjr

  • Main Certifiable NutcAsE
  • Administrator Nut
  • Certifiable Nut
  • *****
  • Posts: 6342
  • Gender: Male
  • Share your life. Be a organ donor other Bday 1998
    • DSLnuts | Broadbandnuts | Cablenut
Re:*Prob w/ SLOW Speed/Need Settings Update*
« Reply #1 on: August 06, 2004, 03:23:54 am »
1. Cable = turn off the modem for 30 minutes give it time to clean out the buggs it picks 2. With it being summer and active squirs.. Have the lines checked for a drop in signal Of course that means having them come out.. Tell them your video keeps dropping during rain storms as well.. Thats the fastest way I know to get them to come out..
3. With all the rain we had here lately all the connections get effected. We had a storm here in Chicago bad enough to take out all of my connections including Cable TV..
Thats the firsttime in over a year..

Check to make sure all the splitters and hopefully its one That all the connections are clean and tight

Do a ping test under load
http://www.broadbandnuts.com/index.php?page=ping
See if your getting packet loss

Be a Organ Donor. A chance at life.
This site never spams or sells its list to anyone. No pop up's or scams
An inconvenience, but if you want to make omelettes, you have to break some eggs.

Offline left4dead

  • A New Nut
  • *
  • Posts: 41
  • I'm a llama!
Re:*Prob w/ SLOW Speed/Need Settings Update*
« Reply #2 on: August 06, 2004, 09:35:18 am »
Hi danjr,

Since I live in Southern California, it hasn't rained in a heck of a long time. :)
My cable company was out a couple of weeks ago to replace the modem and they checked the lines as well. They said everything was normal. Also when doing the ping test, it kept timing out and getting a *

Also do my CN settings look alright or can they be tweaked differently?

mccoffee

  • Guest
Re:*Prob w/ SLOW Speed/Need Settings Update*
« Reply #3 on: August 06, 2004, 12:32:56 pm »
Change thease also i would power cycle for  2mins my guess is adelphia is having routing issuess. I had them same sorts of promblems.  

GlobalMaxTcpWindowSize  and tcpwindowsize 64240
and tcpopts123 to 0