Author Topic: Cablenut settings needed  (Read 2195 times)

Offline System2009

  • A New Nut
  • *
  • Posts: 3
Cablenut settings needed
« on: December 17, 2008, 11:09:01 am »
hello

my speed
2MB - down
512KB - up

connection - pppoe
windows xp sp3

TCP options string: 0204059801010402
MSS: 1432
MTU: 1472
TCP Window: 31944 (NOT multiple of MSS)
RWIN Scaling: 0 bits 
Unscaled RWIN : 31944
Recommended RWINs: 63008, 126016, 252032, 504064, 1008128
BDP limit (200ms): 1278kbps (160KBytes/s)
BDP limit (500ms): 511kbps (64KBytes/s)
MTU Discovery: ON
TTL: 47
Timestamps: OFF
SACKs: ON
IP ToS: 00000000 (0)

thanks :)

Offline mccoffee

  • Administrator Nut
  • Certifiable Nut
  • *****
  • Posts: 3938
Re: Cablenut settings needed
« Reply #1 on: December 17, 2008, 11:54:10 am »
http://www.dslnuts.com/files/cmtu10017.zip

unzip this tool run it type in 1500 apply changes and reboot your mtu is off that is probably throwing off your speed. What brand of modem and or router you have since the mtu could be stuck there as aswell.

Offline System2009

  • A New Nut
  • *
  • Posts: 3
Re: Cablenut settings needed
« Reply #2 on: December 18, 2008, 01:05:24 pm »
but isn't the mtu of a pppoe connection is supposed to be 1492?

Offline mccoffee

  • Administrator Nut
  • Certifiable Nut
  • *****
  • Posts: 3938
Re: Cablenut settings needed
« Reply #3 on: December 18, 2008, 01:15:16 pm »
yes but in xp  if you set it to 1500 sometimes the registy sets it to 1492

Offline System2009

  • A New Nut
  • *
  • Posts: 3
Re: Cablenut settings needed
« Reply #4 on: December 18, 2008, 01:29:16 pm »
ok i used that mtu tool and here is the result

MTU = 1472
MTU is not fully optimized for broadband. Consider increasing your MTU to 1500 for better throughput. If you are using a router, it could be limiting your MTU regardless of Registry settings.
MSS = 1432
Maximum useful data in each packet = 1432, which equals MSS.
Default TCP Receive Window (RWIN) = 937488
RWIN Scaling (RFC1323) = 4 bits (scale factor: 2^4=16)
Unscaled TCP Receive Window = 58593

For optimum performance, consider changing RWIN to a multiple of MSS.
Other RWIN values that might work well with your current MTU/MSS:
63008  (up to 2 Mbit lines, depending on latency. MSS * 44)
126016 (1-5 Mbit lines, depending on latency. MSS * 44 * 2)
252032 (2-14 Mbit lines, depending on latency. MSS * 44 * 2^2)
504064 (8-30 Mbit lines, depending on latency. MSS * 44 * 2^3)
1008128 (25-60 Mbit lines depending on latency. MSS * 44 * 2^4)
bandwidth * delay product (Note this is not a speed test):

Your TCP Window limits you to: 37500 kbps (4687 KBytes/s) @ 200ms
Your TCP Window limits you to: 15000 kbps (1875 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = OFF
Time to live left = 109 hops
TTL value is ok.
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349) = 00000000 (0)


Offline mccoffee

  • Administrator Nut
  • Certifiable Nut
  • *****
  • Posts: 3938
Re: Cablenut settings needed
« Reply #5 on: December 18, 2008, 06:37:36 pm »
What model and brand of modem do you have ?  The mtu could be stuck in the modem's software if you have the manual ,or download the manual see if the mtu could be changed.